re = /^(\s*)(?!pub(?:\s|\(.*?\)\s))(?!_)([_\p{L}][\p{L}0-9_]*\s*:)/m
str = 'struct Foo {
#[some(attr)]
ptr: Bar,
/// pub
/// lorem
inner: Baz,
_marker: Phantom,
///
pub corge: Corge
pub(crate) qux: Qux,
pub(self) quxx: Quxx,
hoge: Hoge,
pub fuga: Fuga,
publish: Pub,
pub_lish: Pub,
}'
subst = '$1pub $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result