using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?i)(javascript|longdesc|src|alt|style|class|title|data\-[\w\-]+)\=\""([\w\s\#]+)?\"")?";
string input = @"<img src=""#"" TITLE=""sdf"" title=""Es una imagen"" data-one=""foo"" class=""a"" style=""s"" data-two=""foo""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}