$re = '/(?:(?i)(javascript|longdesc|src|alt|style|class|title|data\-[\w\-]+)\=\"([\w\s\#]+)?\")?/';
$str = '<img src="#" TITLE="sdf" title="Es una imagen" data-one="foo" class="a" style="s" data-two="foo"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);