import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?i)(javascript|longdesc|src|alt|style|class|title|data\\-[\\w\\-]+)\\=\\\"([\\w\\s\\#]+)?\\\")?";
final String string = "<img src=\"#\" TITLE=\"sdf\" title=\"Es una imagen\" data-one=\"foo\" class=\"a\" style=\"s\" data-two=\"foo\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}