re = /(?:(?i)(javascript|longdesc|src|alt|style|class|title|data\-[\w\-]+)\=\"([\w\s\#]+)?\")?/
str = '<img src="#" TITLE="sdf" title="Es una imagen" data-one="foo" class="a" style="s" data-two="foo"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end