#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+[.][a-zA-Z]+"
Local $sString = "aaa.bbb" & @CRLF & _
"" & @CRLF & _
"fdsg.dfgfd" & @CRLF & _
"" & @CRLF & _
"HH.dd" & @CRLF & _
"" & @CRLF & _
"An example string would look like aaa.bbb dfd gf HH.dd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")