$re = '/[a-zA-Z]+[.][a-zA-Z]+/';
$str = 'aaa.bbb
fdsg.dfgfd
HH.dd
An example string would look like aaa.bbb dfd gf HH.dd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);