re = /[a-zA-Z]+[.][a-zA-Z]+/
str = 'aaa.bbb
fdsg.dfgfd
HH.dd
An example string would look like aaa.bbb dfd gf HH.dd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end