import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+[.][a-zA-Z]+";
final String string = "aaa.bbb\n\n"
+ "fdsg.dfgfd\n\n"
+ "HH.dd\n\n"
+ "An example string would look like aaa.bbb dfd gf HH.dd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}