#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\w+(;\w+)*$)|(^\w+#\w+(;\w+#\w+))*"
Local $sString = "Beispiel1;Beispiel2" & @CRLF & _
"Beispiel1#10;Beispiel2#30" & @CRLF & _
"Beispiel1#10;Beispiel2" & @CRLF & _
"Beispiel1;Beispiel2" & @CRLF & _
"Beispiel1#10;Beispiel2#30"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")