re = /(^\w+(;\w+)*$)|(^\w+#\w+(;\w+#\w+))*/m
str = 'Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30
Beispiel1#10;Beispiel2
Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end