$re = '/(^\w+(;\w+)*$)|(^\w+#\w+(;\w+#\w+))*/m';
$str = 'Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30
Beispiel1#10;Beispiel2
Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);