using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\w+(;\w+)*$)|(^\w+#\w+(;\w+#\w+))*";
string input = @"Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30
Beispiel1#10;Beispiel2
Beispiel1;Beispiel2
Beispiel1#10;Beispiel2#30";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}