const regex = /class="dtend" title="\K[^"]+(?=T)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class="dtend" title="\\K[^"]+(?=T)', 'i')
const str = `</abbr></td><td><abbr class="dtend" title="2014-04-19T00:00:00+00:00">19 Apr 2014</abbr></td></tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}