re = /class="dtend" title="\K[^"]+(?=T)/i
str = '</abbr></td><td><abbr class="dtend" title="2014-04-19T00:00:00+00:00">19 Apr 2014</abbr></td></tr>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end