import re
regex = re.compile(r"class=\"dtend\" title=\"\K[^\"]+(?=T)", flags=re.IGNORECASE)
test_str = "</abbr></td><td><abbr class=\"dtend\" title=\"2014-04-19T00:00:00+00:00\">19 Apr 2014</abbr></td></tr>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")