#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[A-Z]{2}-)\d{4}-\d{2}"
Local $sString = "AR-0000-00 to -88" & @CRLF & _
"AR-0000-00 to 88" & @CRLF & _
"AR-0000-21 to -88" & @CRLF & _
"" & @CRLF & _
"GB-1234-90 to -00" & @CRLF & _
"" & @CRLF & _
"GB-2222-00 to 20" & @CRLF & _
"" & @CRLF & _
"GB-2222-00 to" & @CRLF & _
"" & @CRLF & _
"B-22-00 to 20" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")