$re = '/(?<=[A-Z]{2}-)\d{4}-\d{2}/m';
$str = 'AR-0000-00 to -88
AR-0000-00 to 88
AR-0000-21 to -88
GB-1234-90 to -00
GB-2222-00 to 20
GB-2222-00 to
B-22-00 to 20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);