import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[A-Z]{2}-)\\d{4}-\\d{2}";
final String string = "AR-0000-00 to -88\n"
+ "AR-0000-00 to 88\n"
+ "AR-0000-21 to -88\n\n"
+ "GB-1234-90 to -00\n\n"
+ "GB-2222-00 to 20\n\n"
+ "GB-2222-00 to\n\n"
+ "B-22-00 to 20\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}