using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[A-Z]{2}-)\d{4}-\d{2}";
string input = @"AR-0000-00 to -88
AR-0000-00 to 88
AR-0000-21 to -88
GB-1234-90 to -00
GB-2222-00 to 20
GB-2222-00 to
B-22-00 to 20
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}