using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"OK(*SKIP)^|(?i)\bOK\b";
string input = @"Ok
oK
ok
OK
It's not OK but it is Ok or oK or ok
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}