package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`OK(*SKIP)^|(?i)\bOK\b`)
var str = `Ok
oK
ok
OK
It's not OK but it is Ok or oK or ok
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}