$re = '/OK(*SKIP)^|(?i)\bOK\b/';
$str = 'Ok
oK
ok
OK
It\'s not OK but it is Ok or oK or ok
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);