re = /OK(*SKIP)^|(?i)\bOK\b/
str = 'Ok
oK
ok
OK
It\'s not OK but it is Ok or oK or ok
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end