import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"priceValue\">\\s+)([\\d.]+)*.+(?=</td>)";
final String string = "<tr class=\"tr_standard\"><td>Milk (regular), (1 liter) </td> <td style=\"text-align: right\" class=\"priceValue\"> 2.45 TL</td>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}