use strict;
my $str = '<tr class="tr_standard"><td>Milk (regular), (1 liter) </td> <td style="text-align: right" class="priceValue"> 2.45 TL</td>';
my $regex = qr/(?:"priceValue">\s+)([\d.]+)*.+(?=</td>)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";