re = /(?:"priceValue">\s+)([\d.]+)*.+(?=<\/td>)/
str = '<tr class="tr_standard"><td>Milk (regular), (1 liter) </td> <td style="text-align: right" class="priceValue"> 2.45 TL</td>'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result