# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\"priceValue\">\s+)([\d.]+)*.+(?=</td>)"
test_str = "<tr class=\"tr_standard\"><td>Milk (regular), (1 liter) </td> <td style=\"text-align: right\" class=\"priceValue\"> 2.45 TL</td>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.