package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(*UCP)\d+ :: \w+`)
var str = `1۳۲١८৮੪ :: Aれã¾ëž˜ë„ᚠᚱᚩ`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}