$re = '/(*UCP)\d+ :: \w+/';
$str = '1۳۲١८৮੪ :: Aれã¾ëž˜ë„ᚠᚱᚩ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);