using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?P<command>\w+)\s(?P<name>[^@]+)\@(?P<domain>.+?)$";
string input = @"/start info@example.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}