$re = '/^\/(?P<command>\w+)\s(?P<name>[^@]+)\@(?P<domain>.+?)$/';
$str = '/start info@example.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);