package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/(?P<command>\w+)\s(?P<name>[^@]+)\@(?P<domain>.+?)$`)
var str = `/start info@example.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}