re = /^\/(?P<command>\w+)\s(?P<name>[^@]+)\@(?P<domain>.+?)$/
str = '/start info@example.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end