#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[^'">]*(("[^"]*"|'[^']*')[^'">]*)*>"
Local $sString = "some text <tag link="fo>o"> other text" & @CRLF & _
"some text <tag link="fo>o"> other text" & @CRLF & _
"" & @CRLF & _
"<meta name="keywords" content="javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor" />" & @CRLF & _
"" & @CRLF & _
"<meta name="descrip><>><>tion" content="Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript." />" & @CRLF & _
"" & @CRLF & _
"<meta name="author" content="Firas Dib" />" & @CRLF & _
"content content content " & @CRLF & _
"content <meta property="twitter:ca><<>>><>><>rd" content="summary" />content content " & @CRLF & _
"content content " & @CRLF & _
"content content content <meta property="twitter:site" content="@regex101" />content content content content " & @CRLF & _
"content content content content " & @CRLF & _
"<meta property="twitter:title" content="Regex101 - online regex editor and debugger" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")