# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[^'\">]*((\"[^\"]*\"|'[^']*')[^'\">]*)*>"
test_str = ("some text <tag link=\"fo>o\"> other text\n"
"some text <tag link=\"fo>o\"> other text\n\n"
"<meta name=\"keywords\" content=\"javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor\" />\n\n"
"<meta name=\"descrip><>><>tion\" content=\"Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript.\" />\n\n"
"<meta name=\"author\" content=\"Firas Dib\" />\n"
"content content content \n"
"content <meta property=\"twitter:ca><<>>><>><>rd\" content=\"summary\" />content content \n"
"content content \n"
"content content content <meta property=\"twitter:site\" content=\"@regex101\" />content content content content \n"
"content content content content \n"
"<meta property=\"twitter:title\" content=\"Regex101 - online regex editor and debugger\" />")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.