package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^'">]*(("[^"]*"|'[^']*')[^'">]*)*>`)
var str = `some text <tag link="fo>o"> other text
some text <tag link="fo>o"> other text
<meta name="keywords" content="javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor" />
<meta name="descrip><>><>tion" content="Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript." />
<meta name="author" content="Firas Dib" />
content content content
content <meta property="twitter:ca><<>>><>><>rd" content="summary" />content content
content content
content content content <meta property="twitter:site" content="@regex101" />content content content content
content content content content
<meta property="twitter:title" content="Regex101 - online regex editor and debugger" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}