// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<[^'">]*(("[^"]*"|'[^']*')[^'">]*)*>"#).unwrap();
let string = "some text <tag link=\"fo>o\"> other text
some text <tag link=\"fo>o\"> other text
<meta name=\"keywords\" content=\"javascript,regex><><><<>,regular expression,debugger,explainer,helper,tester,match,pcre,python,editor\" />
<meta name=\"descrip><>><>tion\" content=\"Online reg>---<ex tester, debugger with highlighting for PHP, PCRE, Python and JavaScript.\" />
<meta name=\"author\" content=\"Firas Dib\" />
content content content
content <meta property=\"twitter:ca><<>>><>><>rd\" content=\"summary\" />content content
content content
content content content <meta property=\"twitter:site\" content=\"@regex101\" />content content content content
content content content content
<meta property=\"twitter:title\" content=\"Regex101 - online regex editor and debugger\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}