using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.+)\)\ ?\/\ ?\((.+)\)";
string input = @"<p align=""center"">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*10<sup>-3</sup> + 5) + 9 = <a id=""bya"" href=""javascript:void(0)"" onclick=""Sheet.Refresh(this);"">46.16</a>*10<sup>-3</sup><br><br></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}