const regex = /\((.+)\)\ ?\/\ ?\((.+)\)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.+)\\)\\ ?\\\/\\ ?\\((.+)\\)', 'ig')
const str = `<p align="center">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*10<sup>-3</sup> + 5) + 9 = <a id="bya" href="javascript:void(0)" onclick="Sheet.Refresh(this);">46.16</a>*10<sup>-3</sup><br><br></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}