import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((.+)\\)\\ ?\\/\\ ?\\((.+)\\)";
final String string = "<p align=\"center\">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*10<sup>-3</sup> + 5) + 9 = <a id=\"bya\" href=\"javascript:void(0)\" onclick=\"Sheet.Refresh(this);\">46.16</a>*10<sup>-3</sup><br><br></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}