# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w(?=\w{4})//gm;t' <<< "1234567891234567
123456789
1234567
12345
Z2348348342"