$re = '/\w(?=\w{4})/m';
$str = '1234567891234567
123456789
1234567
12345
Z2348348342';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;