using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class='street-address'>(?<Street>.*?)<\/span>";
string input = @"<span class='street-address'>
2346 21st Ave NE
</span>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}