package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<span class='street-address'>(?<Street>.*?)<\/span>`)
var str = `<span class='street-address'>
2346 21st Ave NE
</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}