re = /<span class='street-address'>(?<Street>.*?)<\/span>/
str = '<span class=\'street-address\'>
2346 21st Ave NE
</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end