$re = '/<span class=\'street-address\'>(?<Street>.*?)<\/span>/s';
$str = '<span class=\'street-address\'>
2346 21st Ave NE
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);