#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[A-Za-z0-9 ]+(?=\|)"
Local $sString = "Manchester United 8547|12345678910" & @CRLF & _
" |12345678910" & @CRLF & _
"Manchester |12345678910" & @CRLF & _
"124587933 |12345678910" & @CRLF & _
"8457 Manchester United|12345678910" & @CRLF & _
" Manchester United|12345678910"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)