const regex = new RegExp('^[A-Za-z0-9 ]+(?=\\|)', 'gm')
const str = `Manchester United 8547|12345678910
|12345678910
Manchester |12345678910
124587933 |12345678910
8457 Manchester United|12345678910
Manchester United|12345678910`;
const subst = `\1\2\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);