import re
regex = re.compile(r"^[A-Za-z0-9 ]+(?=\|)", flags=re.MULTILINE)
test_str = ("Manchester United 8547|12345678910\n"
" |12345678910\n"
"Manchester |12345678910\n"
"124587933 |12345678910\n"
"8457 Manchester United|12345678910\n"
" Manchester United|12345678910")
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)